summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2020-07-19 09:35:53 +0800
committerUniversebenzene2020-07-19 09:35:53 +0800
commit4851c1ea9512bd6d9aeffe73d452099fdff820d8 (patch)
tree6904d606acd4e28657c2876caad9ead61d9e1e56 /PKGBUILD
parent59336eec5a4291f28b0cbcd5f6b092c746ecf372 (diff)
downloadaur-4851c1ea9512bd6d9aeffe73d452099fdff820d8.tar.gz
Update to version 4.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 221b79f87d19..69c89792f5c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
pkgbase=python-baseband
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=3.2.1
+pkgver=4.0
pkgrel=1
pkgdesc="Package to read and write radio baseband data"
arch=('i686' 'x86_64')
url="https://baseband.readthedocs.io"
license=('GPL')
-makedepends=('python-setuptools' 'python-astropy' 'python-sphinx-astropy' 'graphviz')
+makedepends=('python-setuptools-scm' 'python-astropy' 'python-entrypoints' 'python-sphinx-astropy' 'graphviz')
checkdepends=('python-pytest-astropy')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('beae9de373abf398b7d7d93a88866b74')
+md5sums=('71b924b00f6ef6c176ae15cad2fc4736')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -29,7 +29,7 @@ check() {
}
package_python-baseband() {
- depends=('python-numpy>=1.10' 'python-astropy>=4.0')
+ depends=('python-numpy>=1.10' 'python-astropy>=4.0' 'python-entrypoints')
optdepends=('python-baseband-doc: Documentation for Baseband')
cd ${srcdir}/${_pyname}-${pkgver}