summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2020-04-26 23:54:14 +0800
committerUniversebenzene2020-04-26 23:54:14 +0800
commit6b63b8472ecac36dc0738c94c574101e2af0af94 (patch)
tree72400af3fbfa9e34250464be24a05adb058e4f99 /PKGBUILD
parentdf3e58e553604983d0d8297fc091fef07589629b (diff)
downloadaur-6b63b8472ecac36dc0738c94c574101e2af0af94.tar.gz
Update to version 3.1.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa713ce580cc..cb8ab255d6e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,24 @@
pkgbase=python-baseband
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=3.0.0
+pkgver=3.1.1
pkgrel=1
pkgdesc="Package to read and write radio baseband data"
arch=('i686' 'x86_64')
-url="https://baseband.readthedocs.io/"
+url="https://baseband.readthedocs.io"
license=('GPL')
-makedepends=('python-setuptools' 'python-astropy' 'python-astropy-helpers' 'python-sphinx-astropy')
-#checkdepends=('python-pytest-astropy')
-source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('8a31a48460e6418511e113796e8e7d33')
+makedepends=('python-setuptools' 'python-astropy' 'python-astropy-helpers' 'python-sphinx-astropy' 'graphviz')
+checkdepends=('python-pytest-astropy')
+source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
+ 'https://raw.githubusercontent.com/mhvk/baseband/master/AUTHORS.rst')
+md5sums=('f32fa4256e61a7f4ec503c994c8b5eec'
+ 'SKIP')
prepare() {
cd ${srcdir}/${_pyname}-${pkgver}
sed -i -e '/auto_use/s/True/False/' setup.cfg
+ ln -rsf ../AUTHORS.rst .
}
build() {
@@ -27,11 +30,11 @@ build() {
python setup.py build_docs
}
-#check() {
-# cd ${srcdir}/${_pyname}-${pkgver}
+check() {
+ cd ${srcdir}/${_pyname}-${pkgver}
-# python setup.py test
-#}
+ python setup.py test
+}
package_python-baseband() {
depends=('python-numpy>=1.9' 'python-astropy>=2.0')