summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2021-12-01 01:23:01 +0800
committerUniversebenzene2021-12-01 01:23:01 +0800
commita675a0a8ae5bc996f5a0ddd617ddc1ea86a13e27 (patch)
treea2b976466710b62458db6f5718c2fdaab5695985 /PKGBUILD
parent46631cd98e3454660d26de8a07175369e24f6436 (diff)
downloadaur-a675a0a8ae5bc996f5a0ddd617ddc1ea86a13e27.tar.gz
Update to version 4.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d3b031b81ab0..db3cb249c2aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
pkgbase=python-baseband
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=4.0.3
+pkgver=4.1.0
pkgrel=1
pkgdesc="Package to read and write radio baseband data"
-arch=('i686' 'x86_64')
+arch=('any')
url="https://baseband.readthedocs.io"
license=('GPL')
-makedepends=('python-setuptools-scm' 'python-astropy' 'python-entrypoints' 'python-sphinx-astropy' 'graphviz')
-checkdepends=('python-pytest-astropy')
+makedepends=('python-setuptools-scm' 'python-sphinx-astropy' 'python-astropy' 'graphviz')
+checkdepends=('python-pytest-astropy-header')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('8bf1c66eb618fa88c5b2d8285fccb67d')
+md5sums=('625d8a0a815f5c0d3366d0813c8786de')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -29,7 +29,7 @@ check() {
}
package_python-baseband() {
- depends=('python-numpy>=1.17' 'python-astropy>=4.0' 'python-entrypoints')
+ depends=('python-numpy>=1.17' 'python-astropy>=4.0' 'python-importlib-metadata')
optdepends=('python-baseband-doc: Documentation for Baseband')
cd ${srcdir}/${_pyname}-${pkgver}