summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorentshuld2021-08-30 15:52:14 -0500
committerentshuld2021-08-30 15:52:14 -0500
commita51c068d82bbb1c3d1c9031c8ddb767b27a1d481 (patch)
treee66f7e816c8d83dea20725d3fbfc44522a40cd92 /PKGBUILD
parent40f61cb5fb211e8372eb00cf4e0e6142c916a4ca (diff)
downloadaur-a51c068d82bbb1c3d1c9031c8ddb767b27a1d481.tar.gz
hack to last working version from upstream's Git repository
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ff24db854bed..67dd7c01a72d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,11 +9,19 @@ url="https://github.com/FEniCS/basix"
license=('GPL3')
groups=('fenics-git')
depends=('eigen' 'pybind11')
-makedepends=('python-setuptools' 'python-wheel' 'python-scikit-build' 'git' 'ninja')
+makedepends=('python-setuptools' 'python-wheel'
+'python-scikit-build' 'xtensor' 'xtensor-blas' 'git'
+'ninja')
options=(!emptydirs)
source=("basix::git+https://github.com/FEniCS/basix.git")
md5sums=('SKIP')
+
+prepare() {
+ cd basix
+ git checkout $(git rev-list -1 --before="${pkgver:0:4}-${pkgver:4:2}-${pkgver:6:2}" main)
+}
+
pkgver() {
cd basix
git log --format="%cd" --date=short -1 | sed 's/-//g'