summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames An2014-12-05 06:49:36 -0500
committerJames An2014-12-05 06:49:36 -0500
commit7884c83ae8a1ec1a0062f57713893222fc053fcd (patch)
tree8a3eaa1d7f21adfbae37f613209ef6c0d6d2cd05 /PKGBUILD
downloadaur-7884c83ae8a1ec1a0062f57713893222fc053fcd.tar.gz
Created new AUR package, python-bencodepy.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3027c06cd062
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: James An <james@jamesan.ca>
+
+_pkgname=bencodepy
+pkgname=python-${_pkgname}
+pkgver=0.9.4
+pkgrel=1
+pkgdesc='A small Python 3 library for encoding and decoding Bencode data'
+arch=('any')
+url="https://pypi.python.org/pypi/${_pkgname}/${_pkgver}"
+license=('GPL')
+depends=('python')
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}.zip")
+md5sums=('9f769b69deb7ae1b38e448e52b9598f6')
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}