summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornomisge2023-08-12 02:08:24 +0200
committernomisge2023-08-12 02:08:24 +0200
commit2d12e214adaef4bebc31392437b9eb392ca359d2 (patch)
tree69957f689538a64ebaee953cafd2414db0259259 /PKGBUILD
parent0e5211b60fee518404e194980c23e9a9ac4bdc51 (diff)
downloadaur-python-better-exceptions.tar.gz
Fixed checksum
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c562e32bdc19..537e276680d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,9 @@
# Contributor: mdraw.gh at gmail dot com
_name=better-exceptions
-_old_name=better_exceptions
pkgname=python-${_name}
pkgver=0.3.3
-pkgrel=4
+pkgrel=5
pkgdesc="Pretty and helpful exceptions, automatically"
arch=('any')
url="https://github.com/Qix-/${_name}"
@@ -18,10 +17,10 @@ checkdepends=(
'python-pytest'
)
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
-sha256sums=('e4e6bc18444d5f04e6e894b10381e5e921d3d544240418162c7db57e9eb3453b')
+sha256sums=('c4751169b2cc02455738a6c71a3de165145aa9572c833e67556008a205820468')
build() {
- cd "${_old_name}-${pkgver}"
+ cd "${_name}-${pkgver}"
python -m build --wheel --no-isolation
}
@@ -39,6 +38,6 @@ package() {
local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
install -d "$pkgdir/usr/share/licenses/$pkgname/"
ln -s \
- "$_site/${_old_name}-$pkgver.dist-info/LICENSE.txt" \
+ "$_site/${_name}-$pkgver.dist-info/LICENSE.txt" \
"$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}