summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author0b1001002021-10-05 15:55:52 +0200
committer0b1001002021-10-05 15:55:52 +0200
commitc4c3593ef3a08e480de003bc10b7347f781735a8 (patch)
treed5804d68fd11541e5a7d5464cc3297b7b856e764 /PKGBUILD
downloadaur-c4c3593ef3a08e480de003bc10b7347f781735a8.tar.gz
Init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b558e9ef465a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: 0b100100 <0b100100 at protonmail dot ch>
+
+pkgname=python-binance
+pkgver=1.0.15
+pkgrel=1
+pkgdesc="An unofficial Python wrapper for the Binance exchange REST API"
+arch=('any')
+url="https://github.com/sammchardy/python-binance"
+license=('MIT')
+depends=('python' 'python-aiohttp' 'python-dateparser'
+ 'python-requests' 'python-ujson' 'python-websockets=9.1')
+makedepends=('python-setuptools')
+provides=("$pkgname")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/sammchardy/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('38ebb268a94b2c5073a84995474bbb662e17258fa0d5e9ec82c2d57a3b2f01f0')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}