summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNarrat2020-01-18 20:59:24 +0100
committerNarrat2020-01-18 20:59:24 +0100
commit1096f892eb3e3ddc57db91c5dfd9e7259a22f3a9 (patch)
tree93d55c03a9835daf38c789aee7d148d00eddd690 /PKGBUILD
parent981729d7a8c23198d5b7dcb45f613f17660c760b (diff)
downloadaur-1096f892eb3e3ddc57db91c5dfd9e7259a22f3a9.tar.gz
switch back to original repo
and adjust the deps
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 20 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eb9d70edc970..f16a34373223 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,33 @@
+# Contributor: Lex Black <autumn-wind@web.de>
+# Contributor: Eric Toombs
+
_pkgname='python-binance'
pkgname="$_pkgname-git"
-_majmin='0.6.2'
-pkgver=0.6.2.23edd7b
+pkgver=0.7.4.r0.gc4fdad5
pkgrel=1
-pkgdesc="A simple python interface to binance.com's web API."
+pkgdesc="simple python interface to binance.com's web API"
arch=('any')
url='https://github.com/ewtoombs/python-binance'
license=('MIT')
-depends=('python' 'python-requests' 'python-autobahn' 'python-service-identity')
-makedepends=('python-setuptools')
-source=('git+https://github.com/ewtoombs/python-binance.git')
+depends=('python' 'python-autobahn' 'python-certifi' 'python-chardet' 'python-dateparser'
+ 'python-requests' 'python-service-identity' 'python-twisted' 'python-urllib3')
+makedepends=('git' 'python-setuptools')
+source=('git+https://github.com/sammchardy/python-binance.git')
md5sums=('SKIP')
-pkgver () {
- #_date="$(date '+%Y%m%d')"
- cd "$srcdir/$_pkgname"
- echo "$_majmin.$(git rev-parse --short master)"
-}
-package () {
- cd "$srcdir/$_pkgname"
+pkgver() {
+ cd "$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/v//'
+}
- python setup.py install --root="$pkgdir/"
+build() {
+ cd "$_pkgname"
+ python setup.py build
+}
+package() {
+ cd "$_pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
install -D 'LICENSE' "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
}