summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author0b1001002021-10-06 02:47:00 +0200
committer0b1001002021-10-06 02:47:00 +0200
commit75d4bdd2b69b051b933823e890627433367a1c7a (patch)
tree3b1546badcd157172e3db01cc96c0d565c772288 /PKGBUILD
parent851858d444f2947754344d20c18be2eca9c4517d (diff)
downloadaur-75d4bdd2b69b051b933823e890627433367a1c7a.tar.gz
Reverse and add cosmetic changes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 901610d36471..7e1b696b6de3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
# Contributor: Lex Black <autumn-wind@web.de>
# Contributor: Eric Toombs
-pkgname=python-binance-git
+_pkgname=python-binance
+pkgname=$_pkgname-git
pkgver=1.0.15.r2.g217f1e2
pkgrel=1
pkgdesc="An unofficial Python wrapper for the Binance exchange REST API"
@@ -12,23 +13,23 @@ license=('MIT')
depends=('python' 'python-aiohttp' 'python-dateparser'
'python-requests' 'python-ujson' 'python-websockets=9.1')
makedepends=('git' 'python-setuptools')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-source=("git+https://github.com/sammchardy/${pkgname%-git}.git")
-sha256sums=('SKIP')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://github.com/sammchardy/$_pkgname.git")
+sha512sums=('SKIP')
pkgver() {
- cd "${pkgname%-git}"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/v//'
+ cd $_pkgname
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${pkgname%-git}"
+ cd $_pkgname
python setup.py build
}
package() {
- cd "${pkgname%-git}"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE"
+ cd $_pkgname
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$_pkgname
}