summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEric Toombs2018-01-14 18:42:17 -0500
committerEric Toombs2018-01-14 18:42:17 -0500
commit8937479d95aa03557dff1335d958e06d790d3f77 (patch)
treeda66e28ae84982c75759bfc8778f4bb0ac385f89 /PKGBUILD
downloadaur-8937479d95aa03557dff1335d958e06d790d3f77.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..849b43fa044c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+_pkgname='python-binance'
+pkgname="$_pkgname-git"
+_majmin='0.6.2'
+pkgver=0.6.2.745ca91
+pkgrel=1
+pkgdesc="A simple python interface to binance.com's web API."
+arch=('any')
+url='https://github.com/sammchardy/python-binance'
+license=("MIT")
+depends=('python' 'python-requests')
+makedepends=('python-setuptools')
+source=('git+https://github.com/ewtoombs/python-calc.git')
+md5sums=('SKIP')
+
+pkgver () {
+ #_date="$(date '+%Y%m%d')"
+ cd "$srcdir/$_pkgname"
+ echo "$_majmin.$(git rev-parse --short master)"
+}
+
+package () {
+ cd "$srcdir/$_pkgname"
+
+ python setup.py install --root="$pkgdir/"
+
+ install -D 'LICENSE' "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}