diff options
author | Evgeniy Alekseev | 2014-03-18 17:48:00 +0000 |
---|---|---|
committer | Evgeniy Alekseev | 2014-03-18 17:48:00 +0000 |
commit | 93ab8d5f8dd1898a8c379b20b9f2833ebd8b2c33 (patch) | |
tree | 66cc3df08d95202c3cc81014351ed2f907ca56e3 /PKGBUILD | |
parent | 5ea46266a7420066143a19a27efab449f2537434 (diff) | |
download | aur-93ab8d5f8dd1898a8c379b20b9f2833ebd8b2c33.tar.gz |
python3.4 rebuild
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 53 |
1 files changed, 45 insertions, 8 deletions
@@ -3,25 +3,62 @@ # Contributor: Stunts <f.pinamartins at gmail dot com> # Contributor: damir <damir at archlinux dot org> -pkgname=python-biopython -_upstream_pkgname=biopython +pkgname=('python2-biopython' 'python-biopython') +_pkgname=biopython pkgver=1.63 -pkgrel=2 +pkgrel=3 pkgdesc="Freely available Python tools for computational molecular biology" arch=('i686' 'x86_64') url="http://www.biopython.org" license=('custom') -depends=('python-numpy') -source=(http://www.biopython.org/DIST/${_upstream_pkgname}-${pkgver}.tar.gz) +depends=('python2-numpy' 'python-numpy') +source=(http://www.biopython.org/DIST/${_pkgname}-${pkgver}.tar.gz) md5sums=('09c58433150849b131d2d9bbfdf342d3') +prepare() { + cp -r "${_pkgname}-${pkgver}" "${_pkgname}-${pkgver}-py2/" + + cd "${srcdir}/${_pkgname}-${pkgver}-py2/" + # change python to python2 + sed -i "s|python|python2|g" "Bio/bgzf.py" + sed -i "s|python|python2|g" "Bio/DocSQL.py" + sed -i "s|python|python2|g" "Bio/kNN.py" + sed -i "s|python|python2|g" "Bio/LogisticRegression.py" + sed -i "s|python|python2|g" "Bio/PDB/parse_pdb_header.py" + sed -i "s|python|python2|g" "Bio/PDB/PDBList.py" + sed -i "s|python|python2|g" "Bio/Restriction/__init__.py" + sed -i "s|python|python2|g" "Bio/Restriction/PrintFormat.py" + sed -i "s|python|python2|g" "Bio/Restriction/Restriction.py" + sed -i "s|python|python2|g" "Bio/SeqUtils/__init__.py" + sed -i "s|python|python2|g" "Bio/UniProt/GOA.py" + sed -i "s|python|python2|g" "Bio/Wise/__init__.py" + sed -i "s|python|python2|g" "Bio/Wise/dnal.py" + sed -i "s|python|python2|g" "Bio/Wise/psw.py" +} + build() { - cd "${srcdir}/${_upstream_pkgname}-${pkgver}/" + cd "${srcdir}/${_pkgname}-${pkgver}-py2/" + python2 setup.py build + + cd "${srcdir}/${_pkgname}-${pkgver}/" python setup.py build } -package() { - cd "${srcdir}/${_upstream_pkgname}-${pkgver}/" +package_python2-biopython() { + depends=('python2-numpy') + optdepends=('python2-reportlab: for pdf graphics code' + 'mysql-python: for BioSQL module') + + cd "${srcdir}/${_pkgname}-${pkgver}-py2/" + python2 setup.py install --root="${pkgdir}" + install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" +} + +package_python-biopython() { + depends=('python-numpy') + + cd "${srcdir}/${_pkgname}-${pkgver}/" python setup.py install --root="${pkgdir}" install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" } + |