summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJose Riha2021-04-26 07:50:16 +0200
committerJose Riha2021-04-26 07:50:16 +0200
commit2eed4dea9a8906c344ed1ce391b78dbd8d73b3d9 (patch)
tree0ad1da13a5086e5530ec2fea37728b3a6829d7e1 /PKGBUILD
parent0b81315840bd4f6b0f9821057abdd555d6d7b617 (diff)
downloadaur-2eed4dea9a8906c344ed1ce391b78dbd8d73b3d9.tar.gz
Go back to using tarball, add LICENSE (thanks @djmattyg007)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 04df27d5e42e..3dcdd332e9fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,23 @@
pkgname=python-birdseye
_module=birdseye
pkgver=0.9.0
-pkgrel=1
+pkgrel=2
pkgdesc="Graphical Python debugger which lets you view the values of all evaluated expressions"
url="http://github.com/alexmojaki/birdseye"
depends=(python-littleutils python-flask-humanize python-humanize python-flask-humanize python-cheap_repr python-outdated python-sqlalchemy python-cached-property python-future python-asttokens)
makedepends=('python-setuptools')
license=('MIT')
arch=('any')
-source=("https://files.pythonhosted.org/packages/d3/9e/de1d443e0b307f696a9103b4c8fd5e7f253a51a366124139446b7d9c7c23/birdseye-${pkgver}-py3-none-any.whl")
-noextract=("birdseye-${pkgver}-py3-none-any.whl")
-sha256sums=('03c249beaf4770efa8751ed32d5d3c5e6609180339121bc54fbf75531b51fc43')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('c24bbce229b52104554148153bf62cc63096a2cb2b19d4093bb677cd841a9335')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
package() {
- PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${birdseye}/LICENSE"
}