summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-08-16 17:51:30 -0500
committerCarlos Aznarán Laos2022-08-16 17:51:30 -0500
commit6181ebde424c42d6a399983e3c2a8a2580d50b5a (patch)
treef826ea55cd7ac92f1ad4f68ecb59c462e4f7f382 /PKGBUILD
parent99b99315c75735c1fdd846c02528c4f2c4b18aa5 (diff)
downloadaur-6181ebde424c42d6a399983e3c2a8a2580d50b5a.tar.gz
Bump version to 0.9.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 25 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0062f5f13cc1..7765d0649bc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,35 @@
# Maintainer: Jose Riha <jose1711 gmail com>
+# Maintainer: Matthew Gamble <git@matthewgamble.net>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
-pkgname=python-birdseye
-pkgver=0.9.3
-pkgrel=3
+_base=birdseye
+pkgname=python-${_base}
pkgdesc="Graphical Python debugger which lets you view the values of all evaluated expressions"
-url="http://github.com/alexmojaki/birdseye"
-depends=(python-littleutils python-flask-humanize python-humanize python-flask-humanize python-cheap_repr python-outdated python-sqlalchemy python-cached-property python-future python-asttokens)
-makedepends=('python-setuptools-scm' 'python-wheel')
-license=('MIT')
-arch=('any')
-source=("https://files.pythonhosted.org/packages/source/b/birdseye/birdseye-${pkgver}.tar.gz")
-sha256sums=('8a43008afe6c7d54c59a117fe6c818bc8cdd895bb8aa0b0949514073cbe809c0')
+pkgver=0.9.4
+pkgrel=1
+arch=(any)
+url="https://github.com/alexmojaki/${_base}"
+license=(MIT)
+depends=(python-flask-humanize python-sqlalchemy python-asttokens python-littleutils python-cheap_repr python-outdated python-cached-property)
+makedepends=(python-setuptools-scm python-wheel)
+checkdepends=(python-pytest python-markupsafe python-pandas python-beautifulsoup4 python-selenium python-flask) # chromedriver
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('79fe0004c50075080a637b59fdf1731d95404f121770fb18c96377e36f629cbe51b85b2cd1b9bb603625ac995b0cf7f38636bcd530acf4e5d2e8db65ae64c988')
build() {
- cd "birdseye-${pkgver}"
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${pkgver}
+ cd ${_base}-${pkgver}
python setup.py build
}
+check() {
+ cd ${_base}-${pkgver}
+ python -m pytest -k 'not open_with_encoding_check and not against_files and not interface.py'
+}
+
package() {
- cd "birdseye-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-birdseye/LICENSE.txt"
- install -Dm644 README.rst "${pkgdir}/usr/share/doc/python-birdseye/README.rst"
+ cd ${_base}-${pkgver}
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm 644 README.rst -t ${pkgdir}/usr/share/doc/${pkgname}
}