summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJose Riha2021-01-02 16:00:01 +0100
committerJose Riha2021-01-02 16:00:01 +0100
commita83ad102ba53adf62bd36364fe8a68befd124023 (patch)
tree6facfd28a2028393b4e4945bb3d1d3526679d5c4 /PKGBUILD
downloadaur-a83ad102ba53adf62bd36364fe8a68befd124023.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2348c6ff4fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jose Riha <jose1711 gmail com>
+
+pkgname=python-birdseye
+_module=birdseye
+pkgver=0.8.4
+pkgrel=1
+pkgdesc="Graphical Python debugger which lets you view the values of all evaluated expressions"
+url="http://github.com/alexmojaki/birdseye"
+depends=(python-littleutils python-flask-humanize python-humanize python-flask-humanize python-cheap_repr python-outdated python-sqlalchemy python-cached-property python-future python-asttokens)
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('34fbf3a042f257e981cb0d4849d279457269d212851404b19bf9635af71e0701')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}