summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Parrish2020-08-30 11:09:26 -0400
committerDavid Parrish2020-08-30 11:09:26 -0400
commit146d0722777457062f437b1e1083b03688a65442 (patch)
tree06aa3ef8d925e58cd3525cc691174e6559a83fe8 /PKGBUILD
downloadaur-146d0722777457062f437b1e1083b03688a65442.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1156cdae5721
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: David Parrish
+# Contributor: David Parrish <daveparrish@tutanota.com>
+
+pkgname=python-bitcointx
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="An easy interface to the bitcoin transaction data structures"
+arch=('any')
+depends=()
+makedepends=('python-setuptools')
+url="https://github.com/petertodd/python-bitcoinlib"
+license=('LGPL3')
+options=(!emptydirs)
+source=("$pkgname-v$pkgver.tar.gz"::"https://github.com/Simplexum/python-bitcointx/archive/python-bitcointx-v${pkgver}.tar.gz")
+sha256sums=('35edd694473517508367338888633954eaa91b2622b3caada8fd3030ddcacba2')
+
+build() {
+ ls -alh && pwd
+ cd "$srcdir/$pkgname-$pkgname-v$pkgver"
+
+ msg2 'Building...'
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgname-v$pkgver"
+
+ msg2 'Installing...'
+ python setup.py install --root="$pkgdir" --optimize=1
+}