diff options
author | Philip Goto | 2020-09-21 18:01:26 +0200 |
---|---|---|
committer | Philip Goto | 2020-09-21 18:01:26 +0200 |
commit | 54e10503694c8751b2bedec8286eed6d056646fe (patch) | |
tree | 317375873d44713686b59ac8133fd61f9a477aa2 /PKGBUILD | |
parent | d79448dde9bd669d3cc805c3e62fac59c7b48fda (diff) | |
download | aur-54e10503694c8751b2bedec8286eed6d056646fe.tar.gz |
Update to 0.7.1 and use PyPI source
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 39 |
1 files changed, 23 insertions, 16 deletions
@@ -1,22 +1,29 @@ -# Maintainer: Chris Brendel <cdbrendel@gmail.com> -# Python package author: Matthew Honnibal <matt@explosion.ai> +# Maintainer: Philip Goto <philip.goto@gmail.com> +# Contributor: Chris Brendel <cdbrendel@gmail.com> + pkgname=python-blis -_origpkgname=cython-blis -pkgver=0.4.1 +pkgver=0.7.1 pkgrel=1 -pkgdesc="The Blis linear algebra routines as a self-contained Python C-extension" -arch=("x86_64") +pkgdesc="Fast matrix-multiplication as a self-contained Python library" +arch=(i686 x86_64 armv7h aarch64) url="https://github.com/explosion/cython-blis" -license=("MIT") -depends=("cython" "python-numpy" "python-pytest" "python-hypothesis") -makedepends=("python-setuptools" "python-wheel") -source=("$pkgname-$pkgver.tar.gz::https://github.com/explosion/cython-blis/archive/v$pkgver.tar.gz") -md5sums=('277685a789be880d455b8855a550d2ac') +license=(MIT) +depends=(cython + python-numpy + python-pytest + python-hypothesis) +makedepends=(python-setuptools) +source=("https://files.pythonhosted.org/packages/d2/85/b96045fcbd87c8e2e06c7dcd069ccb97e1bf5b6778e0e609a7f965b87e39/blis-0.7.1.tar.gz") +sha256sums=('014771a0f753a64ef5610c5b3d4a090b263073bdd59b8ad0d872ce1e06e7315a') + + +build(){ + cd "blis-${pkgver}" + python setup.py build +} package() { - cd "$_origpkgname-$pkgver" - export BLIS_COMPILER="gcc" - export BLIS_ARCH="x86_64" - python setup.py install --root="${pkgdir}/" --optimize=1 - install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE" + cd "blis-${pkgver}" + python setup.py install --skip-build --root="${pkgdir}" --optimize=1 + install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" } |