summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGI_Jack2023-05-13 20:01:31 -0700
committerGI_Jack2023-05-13 20:01:31 -0700
commit0d294f40bc12709b01860f9451ee8464018f0870 (patch)
treee7727cf09262bc8546f46e2b36b21d649da549b0 /PKGBUILD
parent87b888d52ead4de6e45ac0ca699d19fff4a27046 (diff)
downloadaur-0d294f40bc12709b01860f9451ee8464018f0870.tar.gz
version 1.6.1
updated for modern packaging standards
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 265566ef2320..1acc0918e9a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-bloodhound
_pkgname=bloodhound
-pkgver=1.4.0
+pkgver=1.6.1
pkgrel=1
pkgdesc="Python based ingestor for BloodHound, based on Impacket"
arch=('any')
@@ -10,11 +10,16 @@ url="https://github.com/fox-it/BloodHound.py"
license=('MIT')
groups=()
depends=('python' 'impacket' 'python-ldap3' 'python-dnspython' 'python-future' 'python-pyasn1')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel')
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('609389fcbd0dbf37f56b3e282ee8f584b51c7bbd5235833d9dcd76d476bb591c')
+sha256sums=('4913fbe08e5eb8a244ae74a49ba392740c339effd941e12d346e17a1f9c811e7')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
package() {
- cd ${_pkgname}-${pkgver}
- python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
+ cd "${_pkgname}-${pkgver}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}