summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNils Czernia2020-12-20 18:17:46 +0100
committerNils Czernia2020-12-20 18:18:24 +0100
commitf2780b8ed7847278c8edb48b6a8b4683466bab76 (patch)
tree6df2d8fceb48e7163e69d7de659c4591bbc82caa /PKGBUILD
parent08211e4fd77021fef7df2f6f50606f6793a99370 (diff)
downloadaur-f2780b8ed7847278c8edb48b6a8b4683466bab76.tar.gz
Updated to new build by pip
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bcbccb3e5b6a..9bb232eb309e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=python-bme280-git
_pkgname=bme280
-pkgver=eb28f73
-pkgrel=3
+pkgver=25376a6
+pkgrel=1
pkgdesc="A Python library for accessing the BME280 combined humidity and pressure from Bosch via python-smbus using the I2C interface."
url="https://github.com/cmur2/python-bme280"
arch=("any")
@@ -18,14 +18,10 @@ pkgver() {
git describe --always | sed -e 's|-|.|g'
}
-build() {
- cd "${srcdir}/${_pkgname}"
- python setup.py build
-}
-
package() {
cd "${srcdir}/${_pkgname}"
- python setup.py install --skip-build -O1 --root="${pkgdir}"
+ python -m pip install --root="${pkgdir}" .
+
}
# vim: ts=2 sw=2 et: