summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortaotieren2023-12-21 22:53:01 +0800
committertaotieren2023-12-21 22:53:01 +0800
commitaa2124f877ab7e59d42df136a616bb05ad02e9d7 (patch)
treecbbe5aedf34769fa8dbbdbfaca536920fe995b47 /PKGBUILD
parent669a4190bb3a24894a32fdf433d2130785a47852 (diff)
downloadaur-aa2124f877ab7e59d42df136a616bb05ad02e9d7.tar.gz
[lilac] updated to 0.9.0.r3.g25f7091-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c25aeff65503..1523e034fcda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-booleanoperations-git
pkgver=0.9.0.r3.g25f7091
-pkgrel=1
+pkgrel=2
pkgdesc='Boolean operations on paths'
url='https://github.com/typemytype/booleanOperations'
license=('MIT')
@@ -10,12 +10,13 @@ arch=(any)
_pydeps=(pyclipper
fonttools)
depends=(python
- "${_pydeps[@]/#/python-}")
+ "${_pydeps[@]/#/python-}")
checkdepends=(python-defcon
- python-fontpens
- python-pytest)
-makedepends=(python-setuptools-scm
- git)
+ python-fontpens
+ python-pytest)
+makedepends=(python-{build,installer,wheel}
+ python-setuptools-scm
+ git)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("$pkgname::git+$url.git")
@@ -26,6 +27,11 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare()
+{
+ git -C "${srcdir}/${pkgname}" clean -dfx
+}
+
build() {
cd "$pkgname"
python -m build -wn