summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLukas Fleischer2012-08-15 19:55:21 +0000
committerLukas Fleischer2012-08-15 19:55:21 +0000
commit202981090145027216e03d3756859f5f0c1811f6 (patch)
treee534eb4f74b652e229da32017376bce0c0c721fa /PKGBUILD
parent643bc6aa7733accf94db5ffe68dc01cb422f2b53 (diff)
downloadaur-202981090145027216e03d3756859f5f0c1811f6.tar.gz
Upstream update.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 334e5c35e57e..521844024a87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Aaron Schaefer <aaron@elasticdog.com>
pkgname=python-boto
-pkgver=2.4.1
+pkgver=2.5.2
pkgrel=1
pkgdesc='A Python interface to Amazon Web Services (AWS)'
arch=('any')
@@ -11,19 +11,15 @@ license=('MIT')
depends=('python2')
source=("http://github.com/downloads/boto/boto/boto-$pkgver.tar.gz"
'LICENSE')
-md5sums=('6fb90c1aa8c8ce6d967f2b0e06deda5b'
+md5sums=('be2ed101a4289d1e7271b9371438722d'
'35ebd993c05c79ba78e9f4fb3e65e547')
build() {
cd "$srcdir/boto-$pkgver"
# python2 fix
- for file in boto/{pyami,services}/*.py; do
- sed -i 's_#!/usr/bin/env python_#!/usr/bin/env python2_' $file
- done
- for file in tests/{,s3,devpay}/*.py; do
- sed -i 's_#!/usr/bin/env python_#!/usr/bin/env python2_' $file
- done
+ find . -name '*.py' -type f -print0 | xargs -0 \
+ sed -i 's_#!/usr/bin/env python_#!/usr/bin/env python2_'
python2 setup.py install --root="$pkgdir"
install -D -m644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"