summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfunilrys2022-09-22 20:00:29 +0000
committerfunilrys2022-09-22 20:00:29 +0000
commit0cec991350be26faea4a52ee1bc704827af8da57 (patch)
tree141cf5e28671394cefe55ad443e6f9f777251aee /PKGBUILD
parent185b13cc986b94814e99fed102c35cf18680f4d9 (diff)
downloadaur-0cec991350be26faea4a52ee1bc704827af8da57.tar.gz
fixup! update to 6.0.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 22 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b5653bb92114..c3c80b76f23f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,34 @@
# Maintainer: Nissar Chababy <contact at funilrys dot com>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=python-box
-pkgver=5.4.1
-pkgrel=1
+pkgver=6.0.2
+pkgrel=2
pkgdesc="Advanced Python dictionaries with dot notation access"
-arch=('any')
+arch=('x86_64')
url="https://github.com/cdgriffith/Box"
license=('MIT')
-provides=("${pkgname}")
-depends=(
- 'python-toml'
- 'python-ruamel-yaml'
- 'python-msgpack'
-)
-source=(
- "https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz"
-)
-sha256sums=('b68e0f8abc86f3deda751b3390f64df64a0989459de51ba4db949662a7b4d8ac')
+depends=('python')
+optdepends=(
+ 'python-msgpack'
+ 'python-ruamel-yaml: YAML support'
+ 'python-toml: TOML support'
+ 'python-yaml: YAML support')
+makedepends=('cython' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('c15f09fa2a8730702115396b490ddc17dde3d4276a4f24eb754e35f102c41347')
build() {
- echo "https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz"
- cd ${srcdir}/${pkgname}-${pkgver}
- python setup.py build
+ cd "$pkgname-$pkgver"
+ python -m build --wheel --no-isolation
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+ cd "$pkgname-$pkgver"
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
+ local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
+ install -d "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -s \
+ "$_site/${pkgname/-/_}-$pkgver.dist-info/LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/"
}