summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSimon Boulay2016-01-04 11:34:53 +0100
committerSimon Boulay2016-01-04 11:34:53 +0100
commitee839610385b0ad4f0e8c61a5c5a6fb2ef2aeedb (patch)
treea7255ef744117982a537bc4f58a4600c2b44b4a1 /PKGBUILD
downloadaur-ee839610385b0ad4f0e8c61a5c5a6fb2ef2aeedb.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e596894e33bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Simon Boulay <simon.boulay@alkeona.net>
+
+pkgbase=python-breathe
+pkgname=('python-breathe' 'python2-breathe')
+pkgver=4.1.0
+pkgrel=2
+pkgdesc="An extension to reStructuredText and Sphinx to be able to read and render Doxygen xml output."
+arch=('any')
+url="https://breathe.readthedocs.org/en/latest/"
+license=('BSD')
+makedepends=('python' 'python-setuptools' 'python2' 'python2-setuptools')
+source=("https://pypi.python.org/packages/source/b/breathe/breathe-${pkgver}.tar.gz")
+md5sums=('dd0e39393fd6f21611b479c12e0e972f')
+
+prepare() {
+ cp -a "breathe-$pkgver" "breathe2-$pkgver"
+}
+
+package_python-breathe() {
+ depends=('python' 'python-setuptools')
+
+ cd "breathe-$pkgver"
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+}
+
+package_python2-breathe() {
+ depends=('python2' 'python2-setuptools')
+
+ cd "breathe2-$pkgver"
+ python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+}