summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlsf2020-11-11 18:53:35 +0100
committerlsf2020-11-11 18:53:35 +0100
commita7fd83c856ea7e2c9cd944ac52a8181148eecf8f (patch)
tree55925fdca348d3f2cbc1c1c185f8c76b402f2d55 /PKGBUILD
downloadaur-a7fd83c856ea7e2c9cd944ac52a8181148eecf8f.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a3450e075b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=python-briar-wrapper
+conflicts=('python-briar-wrapper-git')
+pkgver=0.0.6
+pkgrel=1
+pkgdesc='A wrapper for the Briar headless API.'
+arch=('any')
+url='https://code.briarproject.org/briar/python-briar-wrapper'
+license=('GNU Affero GPL')
+makedepends=('python-setuptools' 'python-dephell' 'git')
+depends=('python' 'python-websockets' 'python-requests' 'briar-headless')
+source=("git+https://code.briarproject.org/briar/python-briar-wrapper.git#tag=${pkgver}"
+ 'address_error.patch')
+sha256sums=('SKIP'
+ 'dff2e1645420e76c543065d3bedcfe17fc4669bb01627f6ba43a66c225b52f18')
+
+prepare() {
+ cd "${pkgname}"
+ dephell deps convert --prereleases --from pyproject.toml --to setup.py
+ sed -E 's/packages=\[.*/packages=\["briar_wrapper", "briar_wrapper.models"\],/' -i setup.py
+
+ # fix uncaught OSError / 'Cannot assign requested address' while waiting for briar-headless to come up
+ patch -Np1 -i ../address_error.patch
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}