summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCôme Chilliet2019-08-31 23:48:11 +0200
committerCôme Chilliet2019-08-31 23:48:11 +0200
commit49691c0422d9bad2c5edaad5aa343e4e90599725 (patch)
tree2ef31fc2fd5facd2a233842ef960b6ed06d81fa3 /PKGBUILD
downloadaur-49691c0422d9bad2c5edaad5aa343e4e90599725.tar.gz
Created package for python-bson
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00a38d765747
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Mantainer: MCMic <come@chilliet.eu>
+# Generated with pip2pkgbuild
+
+pkgbase='python-bson'
+pkgname=('python-bson')
+_module='bson'
+pkgver='0.5.8'
+pkgrel=1
+pkgdesc="BSON codec for Python"
+url="http://github.com/py-bson/bson"
+depends=('python')
+makedepends=('python-setuptools')
+license=('BSD')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('13fb1e5486a611374a06177663c2ab878f0c192c8fc8765a63dfef86859006c9')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}