summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGreg Brown2020-04-03 00:37:35 +0100
committerGreg Brown2020-04-03 00:37:35 +0100
commit7d199ec24b41a12008a13817f5ef192c16aa89b2 (patch)
tree8e21629affab829e3433adfb03836e55bc835f1b /PKGBUILD
downloadaur-python-buildbot-gitea.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c54b7e508306
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Greg Brown <greg.brown.00 at outlook dot com>
+_name=buildbot-gitea
+pkgname=python-${_name}
+pkgver=1.2.0
+pkgrel=1
+epoch=
+pkgdesc="Buildbot plugin for integration with Gitea."
+arch=('any')
+url="https://github.com/lab132/buildbot-gitea"
+license=('MIT')
+groups=()
+depends=('buildbot')
+makedepends=('python-setuptools')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname-$pkgver.tar.gz::https://github.com/lab132/$_name/archive/v$pkgver.tar.gz")
+noextract=()
+md5sums=('6cdae14b97bd2c65297af41aa42b8b74')
+validpgpkeys=()
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}