summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChih-Hsuan Yen2018-08-15 21:47:22 +0800
committerChih-Hsuan Yen2018-08-15 21:47:22 +0800
commit02169730beb5b7b247dcb981ce3cdedb1c154e47 (patch)
treeab5411e969608db73ac9ba1b5fa89a74844f7546 /PKGBUILD
downloadaur-02169730beb5b7b247dcb981ce3cdedb1c154e47.tar.gz
update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc1059c52541
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Chih-Hsuan Yen <yan12125@gmail.com>
+
+_pkgname=python-buildbot-pkg
+pkgname=python-buildbot-pkg-git
+pkgdesc="Utilities and common code for building and testing www plugins."
+pkgver=1.2.0.r43.g55fc75395
+pkgrel=2
+arch=('any')
+url="https://buildbot.net"
+license=("GPL")
+depends=('python-setuptools')
+makedepends=('git')
+checkdepends=('python-twisted')
+provides=("$_pkgname=$pkgver")
+conflicts=($_pkgname)
+source=(git+https://github.com/buildbot/buildbot.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd buildbot
+ ( set -o pipefail
+ git describe --long --tag 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+check() {
+ cd buildbot/pkg
+
+ python test_buildbot_pkg.py
+}
+
+package() {
+ cd buildbot/pkg
+ python setup.py install --root="$pkgdir" --optimize=1
+}