summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2020-08-22 16:50:41 +0200
committerGrey Christoforo2020-08-22 16:50:41 +0200
commit83205433e9df3ba24f47af5bdf24f3fbdda42443 (patch)
tree760a57267fcaaf93816eb8821ad25fbdaa9a54f1 /PKGBUILD
parent020f90e723cbfe1369eae623e54a6440772a2601 (diff)
downloadaur-83205433e9df3ba24f47af5bdf24f3fbdda42443.tar.gz
switch to ocp
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cf9919c8d2e6..31e435bcdb18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Grey Christoforo <first name at last name dot net>
pkgname=python-cadquery-git
-pkgver=2.0RC1.r61.g74573fc
+pkgver=2.0.1.r55.gc7b7e95
pkgrel=1
pkgdesc="A parametric CAD scripting framework based on PythonOCC built from git"
arch=('any')
@@ -10,7 +10,7 @@ url="https://github.com/CadQuery/cadquery"
license=('Apache')
provides=('python-cadquery')
conflicts=('python-cadquery')
-depends=('python-occ-cadquery-git' 'python')
+depends=('python-ocp' 'python')
checkdepends=('python-pytest' 'python-pytest-cov')
source=("git+https://github.com/CadQuery/cadquery.git")
@@ -27,8 +27,13 @@ check() {
pytest -v --cov || true
}
+build() {
+ cd cadquery
+ python setup.py build
+}
+
package() {
cd cadquery
- python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}