summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShi Liang2017-11-02 21:56:28 +0800
committerShi Liang2017-11-02 21:56:28 +0800
commitfd98ee786d317a1f20bab551debbf7ad6cfca9d6 (patch)
tree5bfccb3eb2c2177dd321414d2a09448a187aefe8 /PKGBUILD
downloadaur-fd98ee786d317a1f20bab551debbf7ad6cfca9d6.tar.gz
PKGBUILD of CaImAn for Archlinux
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b1f7e167d0a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Shi Liang <shilianggoo@gmail.com>
+pkgname=python-caiman-git
+pkgver=r1421.dd9c889
+pkgrel=1
+
+pkgdesc=" A Computational toolbox for large scale Calcium Imaging data Analysis and behavioral analysis. "
+
+arch=('x86_64')
+url="https://github.com/simonsfoundation/CaImAn.git"
+license=('GPL')
+groups=()
+depends=('python' 'python-numpy' 'python-scipy' 'python-scikit-image' 'python-scikit-learn'
+ 'ipython-ipyparallel' 'opencv' 'python-tifffile' 'python-peakutils')
+makedepends=('git' 'cython')
+checkdepends=()
+optdepends=('python-cvxpy' 'python-spams-svn')
+options=()
+source=("$pkgname-$pkgver::git+${url}")
+md5sums=('SKIP')
+
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build_ext
+ python setup.py build
+}
+
+
+pkgver() {
+ cd "$pkgname-$pkgver"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root=${pkgdir} --prefix=/usr
+ install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+}
+