summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2024-03-28 19:32:56 +0100
committerKlaus Alexander Seistrup2024-03-28 19:32:56 +0100
commit7adb78493d6762b9ab7ee5a144940745b7945cbb (patch)
tree877e2ed437f98b8796c861f1ccc6a7ec6e6b6b2c /PKGBUILD
downloadaur-7adb78493d6762b9ab7ee5a144940745b7945cbb.tar.gz
Initial AUR commit (upstream v1.2.0)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD64
1 files changed, 64 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a499f49a086f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: Klaus Alexander Seistrup <klaus@seistrup.dk>
+# -*- sh -*-
+
+pkgname='python-can_ada-git'
+_pkgname="${pkgname/-git/}"
+_srcname="${_pkgname/python-/}"
+_srcdir="${_srcname}"
+pkgver=1.2.0.r0.g378192b
+pkgrel=1
+pkgdesc='Python bindings for Ada, a fast and WHATWG spec-compliant URL parser (built from latest commit)'
+arch=('aarch64' 'x86_64')
+url="https://github.com/TkTech/$_srcname"
+license=('MIT') # SPDX-License-Identifier: MIT
+makedepends=(
+ 'git'
+ 'pybind11'
+ 'python-build'
+ 'python-installer'
+ 'python-wheel'
+)
+depends=(
+ 'gcc-libs'
+ 'glibc'
+ 'python'
+)
+source=("git+$url.git")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_srcdir"
+
+ git describe --long --tags \
+ | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_srcdir"
+
+ # RFC-0023
+ # 🔗 https://rfc.archlinux.page/0023-pack-relative-relocs/
+ #
+ # ld(1) says: “Supported for i386 and x86-64.”
+ case "${CARCH:-unknown}" in
+ 'x86_64' | 'i386' )
+ export LDFLAGS="$LDFLAGS -Wl,-z,pack-relative-relocs"
+ ;;
+ * ) : pass ;;
+ esac
+
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$_srcdir"
+
+ python -m installer --destdir="$pkgdir" dist/*.whl
+
+ install -Dm0644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# eof