summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Mugnai2024-01-13 10:34:49 +0100
committerMichael Mugnai2024-01-13 10:34:49 +0100
commitcd0d4970f0dc92e32eca9d49753bcbc30b45b5ff (patch)
treea6cdc1836423af5888b8f0447fbafcd5809b8b52 /PKGBUILD
parenta6d7f38bbe4b7338b84874740f1d9980a6ae9874 (diff)
downloadaur-python-cantools.tar.gz
update to 39.4.2, update depends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 24 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c181bb8cb325..cb7f68416a2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,30 +7,46 @@ provides=('python-cantools')
conflicts=('python-cantools')
pkgdesc="Python CAN bus tools in Python 3"
url="https://github.com/eerimoq/cantools"
-pkgver=39.2.0
+pkgver=39.4.2
pkgrel=1
arch=('i686' 'x86_64' 'armv7h')
license=('GPL3')
-makedepends=('python-build' 'python-installer' 'python-wheel')
+makedepends=(
+ 'python-build'
+ 'python-installer'
+ 'python-wheel'
+ 'python-setuptools'
+ 'python-setuptools-scm'
+)
depends=(
- 'python-bitstruct>=6.0.0'
- 'python-can>=2.2.0'
+ 'python>=3.8'
+ 'python-bitstruct>=8.16.1'
+ 'python-can>=3.3.4'
'python-textparser>=0.21.1'
'python-diskcache'
'python-argparse-addons'
+ 'python-crccheck'
+)
+optdepends=(
+ 'python-matplotlib: plot decoded messages'
+ 'mypy'
+ 'python-pipx'
+ 'python-ruff'
+ 'python-tox'
)
-optdepends=('python-matplotlib: plot decoded messages')
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
-md5sums=('42d915595e17133baefdfd5fd0d6613f')
+md5sums=('f0105fa40d814e8830d8999ce154c21f')
build() {
cd "$srcdir/$_gitname-$pkgver"
- python -m build --wheel --no-isolation
+ SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver \
+ python -m build --wheel --no-isolation
}
package() {
cd "$srcdir/$_gitname-$pkgver"
- python -m installer --destdir="$pkgdir" dist/*.whl
+ SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver \
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
}