summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRich Li2018-12-04 11:34:48 -0800
committerRich Li2018-12-04 11:35:15 -0800
commitec0e46c5570493476e527b14c103f385ead58ff2 (patch)
treed323f5652eac1253eaba324c15d48e844be5e44b /PKGBUILD
parent5c65d33f1eee04f1f87b0ff2ada6b252625d63d8 (diff)
downloadaur-ec0e46c5570493476e527b14c103f385ead58ff2.tar.gz
Update dependencies and cartopy to v0.17.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 14 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5ec02538b47b..04d6839ac44d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,25 @@
# Maintainer: Gaute Hope <eg@gaute.vetsj.com>
# Contributor: Rich Li <rich@dranek.com>
pkgname=python-cartopy
-pkgver=0.15.0
+pkgver=0.17.0
pkgrel=1
pkgdesc="A cartographic python library with matplotlib support for visualisation"
url="https://scitools.org.uk/cartopy/docs/latest/"
-depends=('python' 'python-shapely' 'python-pyshp' 'python-pyproj')
-makedepends=('python3' 'cython')
+depends=('python-numpy' 'python-six' 'python-shapely' 'python-pyshp' 'python-pyproj')
+optdepends=('python-fiona: faster shapefile reading'
+ 'python-matplotlib: generate plots'
+ 'python-gdal: for use with SRTM data'
+ 'python-pillow'
+ 'python-scipy'
+ 'python-owslib: access OGC clients')
+makedepends=('python-setuptools' 'cython')
+checkdepends=('python-pytest' 'python-filelock')
license=('LGPL3')
arch=('x86_64')
-source=("https://github.com/SciTools/cartopy/archive/v${pkgver}.tar.gz")
-md5sums=('98da94b1b1f844b31e679bdfdd6e0d96')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/SciTools/cartopy/archive/v${pkgver}.tar.gz")
+md5sums=('9fe063295a9fd854803d3c01a60720d0')
+sha1sums=('f9936ca8639d46a5c265652e383c6d7cabd20c58')
+sha256sums=('137642e63952404ec0841fa0333ad14c58fbbf19cca2a5ac6a38498c4b4998fb')
build() {
cd "$srcdir/cartopy-${pkgver}"