summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBlair Bonnett2020-09-19 18:50:58 +0200
committerBlair Bonnett2020-09-19 18:50:58 +0200
commitec9cddb265d7ef49cb407c2483f5efdcddf525ce (patch)
treefb43b29e64aedf552a47ae4d23a7c5df7e418e66 /PKGBUILD
parent2255aeb1b3ac60d7ddc706b8d1aa5fe293ca4e98 (diff)
downloadaur-ec9cddb265d7ef49cb407c2483f5efdcddf525ce.tar.gz
Update to v0.18.0.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 21 insertions, 32 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 636a19dafe3b..8eec04218acd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,44 @@
# Maintainer: Gaute Hope <eg@gaute.vetsj.com>
+# Maintainer: Blair Bonnett <blair dot bonnett at gmail dot com>
# Contributor: Rich Li <rich@dranek.com>
+
pkgname=python-cartopy
-pkgver=0.17.0
-pkgrel=3
+pkgver=0.18.0
+pkgrel=1
pkgdesc="A cartographic python library with matplotlib support for visualisation"
url="https://scitools.org.uk/cartopy/docs/latest/"
-depends=('python-numpy' 'python-six' 'python-shapely' 'python-pyshp' 'python-pyproj' 'python-matplotlib' 'python-pillow' 'python-scipy')
+depends=('python-numpy' 'python-six' 'python-shapely' 'python-pyshp' 'proj'
+ 'geos' 'python-matplotlib' 'python-pillow' 'python-scipy')
optdepends=('python-fiona: faster shapefile reading'
'python-gdal: for use with SRTM data'
+ 'python-pyepsg: interface to https://epsg.io'
'python-owslib: access OGC clients')
makedepends=('python-setuptools' 'cython')
checkdepends=('python-pytest' 'python-filelock')
license=('LGPL3')
arch=('x86_64')
source=("$pkgname-$pkgver.tar.gz::https://github.com/SciTools/cartopy/archive/v${pkgver}.tar.gz")
-md5sums=('9fe063295a9fd854803d3c01a60720d0')
-sha1sums=('f9936ca8639d46a5c265652e383c6d7cabd20c58')
-sha256sums=('137642e63952404ec0841fa0333ad14c58fbbf19cca2a5ac6a38498c4b4998fb')
-
-prepare() {
- cd "$srcdir/cartopy-${pkgver}"
- # The 0.17.0 release doesn't build against recent releases of PROJ due to
- # API deprecations. This is a temporary hack so at least it compiles
- # against the deprecated API. Hopefully someday this won't be necessary....
- # See also https://github.com/SciTools/cartopy/pull/1289
- sed -i '/# Main setup/iextra_extension_args["define_macros"] = [("ACCEPT_USE_OF_DEPRECATED_PROJ_API_H", None)]\n' setup.py
-}
+md5sums=('792c63511641c843759c5b774f2a8b33')
+sha1sums=('e1eb5b99f8d504ad75e99a788566fcf14da97171')
+sha256sums=('493ced4698361ffabec1a213d2b711dc836117242c304f3b93f5406182fd8bc2')
build() {
cd "$srcdir/cartopy-${pkgver}"
python setup.py build
}
-# NB: the tests are disabled since the tests for version 0.17.0 no longer pass
-# against current versions of libproj. Hopefully they will pass for the next
-# upstream release.
-#
-# check() {
-# cd "$srcdir/cartopy-${pkgver}"
-# # Ignore the warnings (mostly deprecations and such), and also this test
-# # failed for me, so let's disable it for now.
-# pytest --disable-warnings \
-# -k "not test_gridliner" \
-# "build/lib.linux-${CARCH}-3.7/cartopy"
-#
-# # Remove any bytecode files generated from pytest (otherwise they'll be
-# # installed in the package)
-# find "build/lib.linux-${CARCH}-3.7/cartopy/tests" -name '*-PYTEST.pyc' -delete
-# }
+check() {
+ cd "$srcdir/cartopy-${pkgver}"
+
+ # The deselected tests fail an image comparison due to small changes in the
+ # size and position of text labels.
+ PYVER=$(python -c 'import sys; print("{}.{}".format(*sys.version_info[:2]))')
+ PYTHONDONTWRITEBYTECODE=1 pytest \
+ -k "not test_gridliner and not test_contour_label" \
+ "build/lib.linux-${CARCH}-${PYVER}/cartopy"
+}
package() {
cd "$srcdir/cartopy-${pkgver}"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python setup.py install --root="$pkgdir" --prefix=/usr --optimize=1 --skip-build
}