summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKartik Mohta2017-06-02 19:42:25 -0400
committerKartik Mohta2017-06-02 19:42:25 -0400
commit324ca76ef18523bae01d0bae36ef9df38dc35941 (patch)
tree8e9d87780766f100ee95dadfb4118c28dd724546 /PKGBUILD
downloadaur-324ca76ef18523bae01d0bae36ef9df38dc35941.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd167845fe1e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Kartik Mohta <kartikmohta@gmail.com>
+
+pkgbase=('python-catkin_lint')
+pkgname=('python-catkin_lint' 'python2-catkin_lint')
+_module='catkin_lint'
+pkgver='1.4.16'
+pkgrel=1
+pkgdesc="Check catkin packages for common errors"
+url="https://github.com/fkie/catkin_lint"
+depends=()
+makedepends=('python-setuptools' 'python2-setuptools')
+license=('BSD')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/c/catkin_lint/catkin_lint-${pkgver}.tar.gz")
+md5sums=('6252b8ac505cfc0a87d0064e316db460')
+
+prepare() {
+ cp -a "${srcdir}/${_module}-${pkgver}"{,-python2}
+}
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+
+ cd "${srcdir}/${_module}-${pkgver}-python2"
+ python2 setup.py build
+}
+
+package_python-catkin_lint() {
+ depends+=('python' 'python-catkin_pkg')
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
+
+package_python2-catkin_lint() {
+ depends+=('python2' 'python2-catkin_pkg')
+ cd "${srcdir}/${_module}-${pkgver}-python2"
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}