summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordanifr2016-07-26 22:29:19 +0200
committerdanifr2016-07-26 22:29:19 +0200
commit1bdf20dfaa9e08761f522fbd3154c3b65abf8933 (patch)
tree999380b4386dff243f06229b2e447a0a7ac860d7 /PKGBUILD
downloadaur-1bdf20dfaa9e08761f522fbd3154c3b65abf8933.tar.gz
Add python-cec to AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..063c1fcf620d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Daniel Fernandez Rodriguez <gmail.com daferoes>
+pkgname=python-cec
+pkgver=0.2.5
+pkgrel=1
+pkgdesc="libcec bindings for Python"
+arch=('any')
+url="https://github.com/trainman419/python-cec"
+license=('GPL')
+depends=('libcec>=1.6.1')
+makedepends=('git' 'python2-setuptools')
+source=("https://github.com/trainman419/python-cec/archive/$pkgver.tar.gz")
+md5sums=('f086f0f853fbfa5d241ab53c89ea50bf')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ python2 setup.py build
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ python2 setup.py install --root="$pkgdir"
+}