summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorweipeng2023-06-04 18:35:45 +0800
committerweipeng2023-06-04 18:35:45 +0800
commit1e1ab15af94b5bb9718b2949022680ac096189eb (patch)
tree3779fc4eb371054bb6c84bf312ac6cb1ed4afcfe /PKGBUILD
downloadaur-1e1ab15af94b5bb9718b2949022680ac096189eb.tar.gz
a package for scince caculation
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..705c84d09df4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+_name=cf-xarray
+pkgname=python-${_name}
+pkgver=0.8.1
+pkgrel=1
+epoch=
+pkgdesc="A lightweight convenience wrapper for using CF attributes on xarray objects."
+arch=('any')
+url="https://github.com/xarray-contrib/cf-xarray"
+license=('Apache')
+groups=()
+depends=("python-dask" "python-matplotlib" "python-netcdf4" "python-pandas" "python-pooch" "python-xarray")
+makedepends=()
+checkdepends=("python-pytest" "python-pytest-cov" "python-pytest-xdist")
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
+noextract=()
+sha256sums=('4a079a9015f7a46c11792f07bb73610eb0e337daf21b63dc03201ae92ab0996a')
+validpgpkeys=()
+
+prepare() {
+ cd "${srcdir}/${_name}-${pkgver}"
+}
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
+
+check() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ # pytest # can not test due to network requirement
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}
+