summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaesim4042017-01-27 01:13:30 +0200
committerCaesim4042017-01-27 01:13:30 +0200
commitc102d56e505235cc26c6957b8f4ce358fd0dca9e (patch)
tree421f62a2ed6cc222062fd825466142a7ec5d47d7 /PKGBUILD
downloadaur-c102d56e505235cc26c6957b8f4ce358fd0dca9e.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d35d41f0a49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Caesim404 <caesim404 at gmail dot com>
+
+pkgname=python-cfscrape
+_pypiname=${pkgname/python-/}
+pkgver=1.6.8
+pkgrel=1
+pkgdesc="A simple Python module to bypass Cloudflare's anti-bot page, using Requests"
+arch=(any)
+url="https://github.com/Anorov/cloudflare-scrape"
+license=(MIT)
+depends=(python-requests python-js2py)
+makedepends=(python-setuptools)
+source=("https://files.pythonhosted.org/packages/source/${_pypiname::1}/${_pypiname}/${_pypiname}-${pkgver}.tar.gz"
+ "https://raw.githubusercontent.com/Anorov/cloudflare-scrape/master/LICENSE")
+md5sums=("481c7c386904cd75e1cb43decc1b662f"
+ "93d4804f061e05530be1a85b24185408")
+
+
+package() {
+ cd "${srcdir}"
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ cd "${_pypiname}-${pkgver}"
+
+ python setup.py install --root="$pkgdir" --optimize=1
+}