summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJameson Pugh2019-02-11 10:57:18 -0500
committerJameson Pugh2019-02-11 10:57:18 -0500
commitc57c54a281c96b495dda361828f03daa68670f3c (patch)
tree0252be5145c45144a12d7057f7e8bd29af649590 /PKGBUILD
parent591b86fa776fa10225c8a68753ad443848675246 (diff)
downloadaur-c57c54a281c96b495dda361828f03daa68670f3c.tar.gz
2.5.0 (finally)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 696a4205adb7..9cc1d410fa1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,30 @@
# Maintainer: Jameson Pugh <imntreal@gmail.com>
pkgname=python-cheat
-pkgver=2.3.1
+pkgver=2.5.0
pkgrel=1
pkgdesc="Cheat allows you to create and view interactive cheatsheets on the command-line."
url="https://github.com/chrisallenlane/cheat"
-depends=('python' 'python-docopt')
+depends=('python' 'python-docopt' 'python-pygments' 'python-termcolor')
makedepends=('python')
-optdepends=('python-pygments')
+optdepends=('bash-completion' 'zsh-completions' 'fish')
license=('GPL3')
arch=('any')
source=("https://github.com/chrisallenlane/cheat/archive/${pkgver}.tar.gz")
-sha256sums=('f944612b1d1b97dbe87c6cc3c68932df983482f53a09b0446c318ee7399c865c')
+sha256sums=('154379dc3dadb23e270418754c264e4080aba1a4f621d26b3b4abeed71d1d6c9')
build() {
- cd "$srcdir/cheat-${pkgver}"
+ cd "${srcdir}/cheat-${pkgver}"
python setup.py build
}
package() {
- cd "$srcdir/cheat-${pkgver}"
+ cd "${srcdir}/cheat-${pkgver}"
python setup.py install --root="$pkgdir" --optimize=1
+ install -dm755 "${pkgdir}"/usr/share/{bash-completion/completions,zsh/site-functions,fish/completions}
+ install -m 644 cheat/autocompletion/cheat.bash "${pkgdir}/usr/share/bash-completion/completions/cheat"
+ install -m 644 cheat/autocompletion/cheat.zsh "${pkgdir}/usr/share/zsh/site-functions/cheat"
+ install -m 644 cheat/autocompletion/cheat.fish "${pkgdir}/usr/share/fish/completions/cheat"
}
# vim:set ts=2 sw=2 et: