summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKyle Manna2020-12-06 08:04:31 -0800
committerKyle Manna2020-12-06 08:05:09 -0800
commit3e4a250c9f05bd489725ac35bc83c9ab56165643 (patch)
treefb51db8fb37aa9c96faec576311dd29d6f2fc15d /PKGBUILD
parentdf35fdf38465d3ef72bd026c934b1e0319ace251 (diff)
downloadaur-3e4a250c9f05bd489725ac35bc83c9ab56165643.tar.gz
release: v3.0.5
* Follow backblaze-b2 dependencies.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1dde48822a69..034d0bde0cab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Kyle Manna <kyle[at]kylemanna[d0t]com>
pkgname=python-class-registry
_pkgname=class-registry
-pkgver=2.1.2
-pkgrel=2
+pkgver=3.0.5
+pkgrel=1
pkgdesc='The intersection of the Registry and Factory patterns'
url='https://github.com/todofixthis/class-registry'
depends=('python')
@@ -11,7 +11,7 @@ optdepends=()
license=('MIT')
arch=('any')
source=("https://github.com/todofixthis/${_pkgname}/archive/${pkgver}.tar.gz")
-sha512sums=('365e8e526cdad3730f946e0cb111dcee88bb72305015551d7da4419d18f41d98b960620f03665b684de17d1c868d6723ebdda6960324982e8648e99606315426')
+sha512sums=('324171cbf14132e02c58026d90c87d408fd321d95258cf8cd66de472a125177c4131ca1e47fad279db3384a8a3a50832eb1287a4b577c76c79a9391fa1d998c6')
build() {
cd "$srcdir/$_pkgname-$pkgver"
@@ -21,5 +21,7 @@ build() {
package() {
cd "$srcdir/$_pkgname-$pkgver"
python3 setup.py install --root="$pkgdir" --optimize=1
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}