summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCayetano Santos2020-03-21 12:19:49 +0100
committerCayetano Santos2020-03-21 12:19:49 +0100
commit3594d82be7d2469ff9d126dd4673306745384de6 (patch)
tree4185aff7f4ad6a837eddb97589cdf28918953a1c /PKGBUILD
parent2006eeb20bb5d6a7564e1f3ec5c66b7437e7b770 (diff)
downloadaur-3594d82be7d2469ff9d126dd4673306745384de6.tar.gz
independent repo python-cocotb
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a2c2108c6baa..957aac432446 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,26 @@
-# Maintainer: mox <demox@lavabit.com>
-pkgname=cocotb
+# Maintainer: csantosb <csantosb dot inventati dot org>
+pkgname=python-cocotb
pkgver=1.3
pkgrel=1
-epoch=0
pkgdesc="Coroutine based cosimulation library for writing VHDL and Verilog testbenches in Python"
-arch=('x86_64') # Can probably support other architectures as well, try your luck?
+arch=('any')
url="http://github.com/cocotb/cocotb/"
license=('BSD')
-conflicts=('cocotb')
-provides=('cocotb')
+conflicts=('python-cocotb')
+provides=('python-cocotb')
depends=('python')
+
+makedepends=('git' 'python-setuptools')
optdepends=('iverilog: for simulating verilog designs'
'ghdl: for simulating VHDL designs'
'gtkwave: for visualizing waveforms')
-install=${pkgname}.install
-source=("https://github.com/cocotb/$pkgname/archive/v$pkgver.$pkgrel.tar.gz")
-md5sums=('0d9dd62350649c91c9a4fa202ad20dda')
+options=(!emptydirs)
+source=("git+https://github.com/cocotb/cocotb#tag=v${pkgver}.${pkgrel}")
+md5sums=('SKIP')
package() {
- cd "${srcdir}/cocotb-$pkgver.$pkgrel"
+ cd "${srcdir}/cocotb"
python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
install -m 644 -D ./LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
}