summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFelipe F. Tonello2016-07-22 15:25:51 +0100
committerFelipe F. Tonello2016-07-22 15:25:51 +0100
commite2c0cd9f38526e6c618f173f80b71d408d22a985 (patch)
tree8d5eaaa69bbfd338ab2997ce3d179b3733753bdf /PKGBUILD
parenta4c4d72041f030c033ba4b1e394f879ba6725023 (diff)
downloadaur-e2c0cd9f38526e6c618f173f80b71d408d22a985.tar.gz
Use python-setuptools proper dependency
Signed-off-by: Felipe F. Tonello <eu@felipetonello.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7c6cca10a46a..44e771115a7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,17 @@ pkgbase=python-codegen
_pkgbase=codegen
pkgname=('python-codegen' 'python2-codegen')
pkgver=1.0
-pkgrel=2
+pkgrel=3
pkgdesc="Extension to ast that allow ast -> python code generation."
arch=('any')
url="http://github.com/andreif/codegen"
license=('BSD')
-makedepends=('python2' 'python3')
+makedepends=('python2-setuptools' 'python-setuptools')
source=(https://github.com/andreif/${_pkgbase}/archive/${pkgver}.tar.gz)
md5sums=('3700a064df8c1d3915bfe2944ece9d33')
package_python-codegen() {
- depends=('python3')
+ depends=('python-setuptools')
cd ${srcdir}/${_pkgbase}-${pkgver}
python3 setup.py install --root ${pkgdir} --prefix=/usr
@@ -23,7 +23,7 @@ package_python-codegen() {
}
package_python2-codegen() {
- depends=('python2')
+ depends=('python2-setuptools')
cd ${srcdir}/${_pkgbase}-${pkgver}
python2 setup.py install --root ${pkgdir} --prefix=/usr