summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZhirui Dai2024-03-26 12:33:55 -0700
committerZhirui Dai2024-03-26 12:33:55 -0700
commite0bf8fc245e7c2dad2f44b632006b4d553e30f04 (patch)
treec71dc38c32531fba2f5c7017be01599301a845e3 /PKGBUILD
parent49fa5528191d5899c03720a89dd48d414de57212 (diff)
downloadaur-python-colcon-core.tar.gz
update makedepends, upgrade to 0.16.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 19 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 17226ac78763..23321598867a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,31 @@
# Contributor: Tong Chunli<t.cunly at 163 dot com>
pkgname=python-colcon-core
-pkgver=0.15.2
+pkgver=0.16.0
pkgrel=1
pkgdesc="Command line tool to build sets of software packages."
arch=(any)
url="https://colcon.readthedocs.io/en/released/"
license=('Apache')
-depends=('python-pytest' 'python-pytest-runner' 'python-pytest-rerunfailures'
- 'python-pytest-repeat' 'python-coverage' 'python-pytest-cov'
- 'python-distlib' 'python-notify2' 'python-empy3')
-makedepends=('python-setuptools')
+depends=(
+ python-pytest
+ python-pytest-runner
+ python-pytest-rerunfailures
+ python-pytest-repeat
+ python-coverage
+ python-pytest-cov
+ python-distlib
+ python-notify2
+ python-empy3
+)
+makedepends=(
+ python-setuptools
+ python-build
+ python-installer
+ python-wheel
+)
source=("$pkgname-$pkgver.tar.gz"::"https://github.com/colcon/colcon-core/archive/$pkgver.tar.gz")
-sha256sums=('2eebc46d001163a70c37bff57c5cc83c694563ff75b5178bcd2a24d6ff0cb645')
+sha256sums=('223e3096b75e4c1537861a0d95585ce8306a7d3ac796c0944658d932eca15539')
_pkgname=colcon-core