summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoryochananmarqos2019-12-24 16:37:02 -0700
committeryochananmarqos2019-12-24 16:37:02 -0700
commit3bf60e014a3614f7f31e1f2f76e086d22934fb75 (patch)
treeca7d57bc8dedacbfd69805e551efe6aa5e3281d5 /PKGBUILD
downloadaur-3bf60e014a3614f7f31e1f2f76e086d22934fb75.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b6f81043126
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=python-colorful
+pkgver=0.5.4
+pkgrel=1
+pkgdesc="Terminal string styling done right, in Python"
+arch=('any')
+url="https://github.com/timofurrer/colorful"
+license=('GPL')
+depends=('python')
+makedepends=('python-setuptools')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('6800079a7bd4a3d17b4915b195267f80802703df8fe276565e5cedf7691807dd')
+
+build() {
+ cd "colorful-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "colorful-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}