summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Rosenstrauch2023-07-25 16:50:09 -0400
committerDavid Rosenstrauch2023-07-25 16:50:09 -0400
commitf2e18cf26d6a743933381b729a808a3096f10ddc (patch)
tree2bcaf1c52daece875d13f6fd2e104e084017072c /PKGBUILD
parent3929ac45b2c3a7740cd4255c3011b01d5a8bd89e (diff)
downloadaur-f2e18cf26d6a743933381b729a808a3096f10ddc.tar.gz
v0.4.27
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d39e10866beb..37d024b2e651 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,22 @@
pkgbase='python-common-ta-lib'
pkgname=("python-ta-lib")
-pkgver=0.4.26
+pkgver=0.4.27
pkgrel=1
pkgdesc="Python wrapper for TA-Lib"
url="https://github.com/TA-Lib/ta-lib-python"
makedepends=('python-setuptools' 'python-numpy' 'cython' 'ta-lib')
license=('BSD')
arch=('any')
-source=("https://pypi.python.org/packages/source/T/TA-Lib/TA-Lib-$pkgver.tar.gz")
-sha256sums=('9a1e87ead8990f5c344184e17f268b4f6f50532ea9d40fb7fd161ce5197716da')
+source=("https://github.com/TA-Lib/ta-lib-python/archive/refs/tags/TA_Lib-$pkgver.tar.gz")
+sha256sums=('6d81479267330475f17c114ed4c92641d8a75ecc3dd11172c42f2a1cd157cd4c')
prepare() {
- sed -r 's/raise.*build_ext overridden.*/return/' -i TA-Lib-$pkgver/setup.py
+ sed -r 's/raise.*build_ext overridden.*/return/' -i ta-lib-python-TA_Lib-$pkgver/setup.py
}
build() {
- cd "$srcdir"/TA-Lib-$pkgver
+ cd "$srcdir"/ta-lib-python-TA_Lib-$pkgver
python setup.py build
}
@@ -26,6 +26,6 @@ package_python-ta-lib() {
depends=('python-numpy' 'ta-lib')
optdepends=('cython')
- cd $srcdir/TA-Lib-$pkgver
+ cd $srcdir/ta-lib-python-TA_Lib-$pkgver
python setup.py install -O1 --skip-build --root="$pkgdir"
}