summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2019-08-17 21:19:52 -0400
committerGuillaume Horel2019-08-17 21:19:52 -0400
commitd92a0c89169de649d48ca710ab65ec7a2fc338c3 (patch)
treefa50d9189923fc59594a749d3cda5344ea0ebe3a /PKGBUILD
downloadaur-d92a0c89169de649d48ca710ab65ec7a2fc338c3.tar.gz
initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..090f893fd6be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname=('python-compreffor')
+_pkgname='compreffor'
+pkgver='0.4.6.post1'
+pkgrel=1
+pkgdesc="A CFF table suroutinizer for FontTools."
+url="https://github.com/googlefonts/compreffor"
+checkdepends=()
+depends=('python' 'python-fonttools')
+makedepends=('cython' 'python-setuptools')
+optdepends=()
+license=('Apache')
+arch=('x86_64')
+source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip")
+sha256sums=('6e3027d0247f3c52dbda7bce1143c9e2c7aa4a496c8e0d76d7dc424bfc9a6749')
+
+check() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py test
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}