summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarco Rubin2022-07-23 14:03:40 +0200
committerMarco Rubin2022-07-23 14:03:40 +0200
commit6fc3b8ef6139c530cc3500acb5e02822c1248ee5 (patch)
treeb15e0617a2fe237119c5332cb6c0120c72a036a9 /PKGBUILD
downloadaur-6fc3b8ef6139c530cc3500acb5e02822c1248ee5.tar.gz
1.3.9
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..665d68db4324
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Marco Rubin <marco.rubin@protonmail.com>
+
+_name=concur_imgui
+pkgname=python-concur-imgui
+pkgver=1.3.9
+pkgrel=1
+pkgdesc='Cython-based Python bindings for dear imgui (Concur fork)'
+arch=(x86_64)
+url='https://github.com/pyimgui/pyimgui'
+license=('MIT')
+depends=(python)
+makedepends=(python-build python-installer python-wheel)
+provides=(python-imgui)
+conflicts=(python-imgui)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('f6e7e71ffaccedb293f5af9cc477fae873fe2d34b30e7235def3f52dfa05fa94')
+
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}