summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Dewender2013-10-17 21:24:54 +0200
committerJohannes Dewender2013-10-17 21:24:54 +0200
commit89bfea18a95ccfcece3c4953ba5de978c8e69f1d (patch)
treefffe5b9c7df26a1ad42c685e8b562332104cdbfa /PKGBUILD
downloadaur-89bfea18a95ccfcece3c4953ba5de978c8e69f1d.tar.gz
python-configshell-fb: create as 1.1.fb9
using 2to3 patch from upstream
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..afef55390027
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: Johannes Dewender arch at JonnyJD dot net
+pkgname=python-configshell-fb
+_pkgname=configshell-fb
+pkgver=1.1.fb9
+pkgrel=1
+epoch=
+pkgdesc="python framework for building simple CLI applications (free branch)"
+arch=('any')
+url="https://github.com/agrover/configshell-fb"
+license=('Apache')
+depends=('python-pyparsing' 'python-urwid')
+provides=('python-configshell')
+conflicts=('python-configshell')
+options=()
+source=(https://fedorahosted.org/releases/t/a/targetcli-fb/$_pkgname-$pkgver.tar.gz 2to3.patch)
+md5sums=('48b7c9be66c9e450585598504c2fde45'
+ 'd0413e9d1a8dca6df0c92aa9a4a2bf54')
+
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ patch -p1 < ../2to3.patch
+}
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --skip-build --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: