summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNarrat2023-07-05 22:39:05 +0200
committerNarrat2023-07-05 22:39:05 +0200
commit265965a6561354145b0631ddad547a697e94e195 (patch)
tree30dd28c041fa062dd0b8f79ce4fb1e316edb9a97 /PKGBUILD
downloadaur-265965a6561354145b0631ddad547a697e94e195.tar.gz
python-configula: initial commit
needed for papermerge-core
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28bf0b47e3bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Lex Black <autumn-wind@web.de>
+
+_module=configula
+pkgname=python-${_module}
+pkgver=0.5.2
+pkgrel=1
+pkgdesc="creates config for papermerge-core"
+arch=(any)
+url="https://github.com/papermerge/configula"
+license=(Apache)
+depends=(python-tomlkit)
+makedepends=(python-build python-installer python-wheel python-poetry-core)
+source=(https://files.pythonhosted.org/packages/source/${_module::1}/$_module/${_module//-/_}-$pkgver.tar.gz)
+sha256sums=('d293087a584ff94c48b96b9bb0b1ae9cbc61ed1efdacd6bf66ffd750c91d900a')
+
+
+build() {
+ cd "${_module//-/_}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "${_module//-/_}-${pkgver}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}