summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNarrat2023-07-06 00:19:23 +0200
committerNarrat2023-07-06 00:19:23 +0200
commit2a869cbc937c1e3ecb6e688b5c0a93277669d0ed (patch)
tree96f7aee8a9e098ad657cc0b390dec1bcaa754f6d /PKGBUILD
parent265965a6561354145b0631ddad547a697e94e195 (diff)
downloadaur-2a869cbc937c1e3ecb6e688b5c0a93277669d0ed.tar.gz
python-configula: remove files from base site-packages
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28bf0b47e3bb..77be2236719d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,25 @@
_module=configula
pkgname=python-${_module}
pkgver=0.5.2
-pkgrel=1
+pkgrel=2
pkgdesc="creates config for papermerge-core"
arch=(any)
url="https://github.com/papermerge/configula"
license=(Apache)
depends=(python-tomlkit)
makedepends=(python-build python-installer python-wheel python-poetry-core)
-source=(https://files.pythonhosted.org/packages/source/${_module::1}/$_module/${_module//-/_}-$pkgver.tar.gz)
-sha256sums=('d293087a584ff94c48b96b9bb0b1ae9cbc61ed1efdacd6bf66ffd750c91d900a')
+source=(https://files.pythonhosted.org/packages/source/${_module::1}/$_module/${_module//-/_}-$pkgver.tar.gz
+ 001_files-in-base.patch)
+sha256sums=('d293087a584ff94c48b96b9bb0b1ae9cbc61ed1efdacd6bf66ffd750c91d900a'
+ 'ebf889321789bd70fe010518a57a42df47ac4ca964fcd02d6cc8d7a145aca43a')
+prepare() {
+ cd "${_module//-/_}-${pkgver}"
+ # Without this patch files would get installed into base site-packages dir
+ patch -Np1 -i "${srcdir}"/001_files-in-base.patch
+}
+
build() {
cd "${_module//-/_}-${pkgver}"
python -m build --wheel --no-isolation