summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTyler Veness2021-03-22 15:02:08 -0700
committerTyler Veness2021-03-22 15:02:51 -0700
commit1e9b43ae702b214d7a871fd30958a32d8186fcbc (patch)
tree1306d2dfe7037c8af0df98384a6b58e145ac5540 /PKGBUILD
parentb4b7377d1c431e2a33761fb07dc9da7713541a81 (diff)
downloadaur-1e9b43ae702b214d7a871fd30958a32d8186fcbc.tar.gz
upgpkg python-control-git 970.6ede92e
Fix test invocation for control 0.9.0.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3596c5e87f71..f9a5ad056197 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=python-control-git
pkgname=('python2-control-git' 'python-control-git')
-pkgver=662.601b581
+pkgver=970.6ede92e
pkgrel=1
pkgdesc="Implements basic operations for analysis and design of feedback control systems in Python"
arch=('any')
@@ -12,7 +12,7 @@ depends=('python-scipy'
'python-matplotlib')
optdepends=('python-slycot-git: matrix equation support, model simplification tools, and state feedback')
makedepends=('git' 'python-setuptools' 'python2-setuptools')
-checkdepends=('python-nose' 'python2-nose' 'python-slycot-git')
+checkdepends=('python-nose' 'python2-nose' 'python-slycot-git' 'xorg-server-xvfb')
options=('staticlibs')
source=("git+https://github.com/python-control/python-control.git"
"LICENSE")
@@ -48,7 +48,7 @@ build() {
check() {
cd python-control
- python setup.py test
+ xvfb-run --auto-servernum pytest control/tests
}
package_python2-control-git() {