summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTyler Veness2021-03-25 01:08:58 -0700
committerTyler Veness2021-03-25 01:08:58 -0700
commit56d2fbc011ec9029e1021cac2a4d26bc1d68e51f (patch)
treeb8b7cabd9d1688fd1f649caa8a97ba375b9687e5 /PKGBUILD
parent1e9b43ae702b214d7a871fd30958a32d8186fcbc (diff)
downloadaur-56d2fbc011ec9029e1021cac2a4d26bc1d68e51f.tar.gz
Remove python 2 support and add pytest to checkdepends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 6 insertions, 34 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f9a5ad056197..5a6b9e90fbe5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
# Maintainer: Tyler Veness <calcmogul at gmail dot com>
-pkgbase=python-control-git
-pkgname=('python2-control-git' 'python-control-git')
-pkgver=970.6ede92e
+pkgname=python-control-git
+pkgver=1318.203cae8
pkgrel=1
pkgdesc="Implements basic operations for analysis and design of feedback control systems in Python"
arch=('any')
@@ -11,8 +10,8 @@ url="https://github.com/python-control/python-control"
depends=('python-scipy'
'python-matplotlib')
optdepends=('python-slycot-git: matrix equation support, model simplification tools, and state feedback')
-makedepends=('git' 'python-setuptools' 'python2-setuptools')
-checkdepends=('python-nose' 'python2-nose' 'python-slycot-git' 'xorg-server-xvfb')
+makedepends=('git' 'python-setuptools')
+checkdepends=('python-nose' 'python-pytest' 'python-slycot-git' 'xorg-server-xvfb')
options=('staticlibs')
source=("git+https://github.com/python-control/python-control.git"
"LICENSE")
@@ -24,25 +23,10 @@ pkgver() {
echo $(git rev-list --count master).$(git rev-parse --short master)
}
-prepare() {
- cp -a python-control python2-control
- cd python2-control
-
- sed -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
- -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
- -e "s|#![ ]*/bin/env python$|#!/usr/bin/env python2|" \
- -i $(find . -name '*.py')
-}
-
build() {
export LDFLAGS="$LDFLAGS -shared"
- echo "Building Python2"
- cd python2-control
- python2 setup.py build
-
- echo "Building Python3"
- cd ../python-control
+ cd python-control
python setup.py build
}
@@ -51,19 +35,7 @@ check() {
xvfb-run --auto-servernum pytest control/tests
}
-package_python2-control-git() {
- export LDFLAGS="$LDFLAGS -shared"
-
- cd python2-control
- python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
-
- install -m755 -d "${pkgdir}/usr/share/licenses/python2-control"
- install -m644 ../LICENSE "${pkgdir}/usr/share/licenses/python2-control/"
-}
-
-package_python-control-git() {
- provides=('python3-control')
-
+package() {
export LDFLAGS="$LDFLAGS -shared"
cd python-control